aboutsummaryrefslogtreecommitdiff
path: root/sys/contrib/openzfs/man/man5/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/contrib/openzfs/man/man5/Makefile.am')
-rw-r--r--sys/contrib/openzfs/man/man5/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/sys/contrib/openzfs/man/man5/Makefile.am b/sys/contrib/openzfs/man/man5/Makefile.am
new file mode 100644
index 000000000000..9cbb2c08f378
--- /dev/null
+++ b/sys/contrib/openzfs/man/man5/Makefile.am
@@ -0,0 +1,16 @@
+dist_man_MANS = \
+ vdev_id.conf.5 \
+ zpool-features.5 \
+ spl-module-parameters.5 \
+ zfs-module-parameters.5 \
+ zfs-events.5
+
+if BUILD_LINUX
+# The man pager in most Linux distros defaults to BSD instead of Linux
+# when .Os is blank, but leaving it blank makes things a lot easier on
+# FreeBSD when OpenZFS is vendored in the base system.
+install-data-hook:
+ cd $(DESTDIR)$(mandir)/man5; \
+ $(SED) ${ac_inplace} -e 's/^\.Os$$/.Os Linux/' \
+ $(dist_man_MANS)
+endif