aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test')
-rw-r--r--packages/Python/lldbsuite/test/decorators.py47
-rw-r--r--packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-objc/TestDataFormatterObjC.py15
-rw-r--r--packages/Python/lldbsuite/test/functionalities/ubsan/basic/Makefile6
-rw-r--r--packages/Python/lldbsuite/test/functionalities/ubsan/basic/TestUbsanBasic.py90
-rw-r--r--packages/Python/lldbsuite/test/functionalities/ubsan/basic/main.c4
-rw-r--r--packages/Python/lldbsuite/test/lang/objc/objc-new-syntax/TestObjCNewSyntax.py4
6 files changed, 160 insertions, 6 deletions
diff --git a/packages/Python/lldbsuite/test/decorators.py b/packages/Python/lldbsuite/test/decorators.py
index 866923607867..2a36ee4b3707 100644
--- a/packages/Python/lldbsuite/test/decorators.py
+++ b/packages/Python/lldbsuite/test/decorators.py
@@ -681,6 +681,53 @@ def skipUnlessThreadSanitizer(func):
return None
return skipTestIfFn(is_compiler_clang_with_thread_sanitizer)(func)
+def skipUnlessUndefinedBehaviorSanitizer(func):
+ """Decorate the item to skip test unless -fsanitize=undefined is supported."""
+
+ def is_compiler_clang_with_ubsan(self):
+ # Write out a temp file which exhibits UB.
+ inputf = tempfile.NamedTemporaryFile(suffix='.c')
+ inputf.write('int main() { int x = 0; return x / x; }\n')
+ inputf.flush()
+
+ # We need to write out the object into a named temp file for inspection.
+ outputf = tempfile.NamedTemporaryFile()
+
+ # Try to compile with ubsan turned on.
+ cmd = '%s -fsanitize=undefined %s -o %s' % (self.getCompiler(), inputf.name, outputf.name)
+ if os.popen(cmd).close() is not None:
+ return "Compiler cannot compile with -fsanitize=undefined"
+
+ # Check that we actually see ubsan instrumentation in the binary.
+ cmd = 'nm %s' % outputf.name
+ with os.popen(cmd) as nm_output:
+ if '___ubsan_handle_divrem_overflow' not in nm_output.read():
+ return "Division by zero instrumentation is missing"
+
+ # Find the ubsan dylib.
+ # FIXME: This check should go away once compiler-rt gains support for __ubsan_on_report.
+ cmd = '%s -fsanitize=undefined -x c - -o - -### 2>&1' % self.getCompiler()
+ with os.popen(cmd) as cc_output:
+ driver_jobs = cc_output.read()
+ m = re.search(r'"([^"]+libclang_rt.ubsan_osx_dynamic.dylib)"', driver_jobs)
+ if not m:
+ return "Could not find the ubsan dylib used by the driver"
+ ubsan_dylib = m.group(1)
+
+ # Check that the ubsan dylib has special monitor hooks.
+ cmd = 'nm -gU %s' % ubsan_dylib
+ with os.popen(cmd) as nm_output:
+ syms = nm_output.read()
+ if '___ubsan_on_report' not in syms:
+ return "Missing ___ubsan_on_report"
+ if '___ubsan_get_current_report_data' not in syms:
+ return "Missing ___ubsan_get_current_report_data"
+
+ # OK, this dylib + compiler works for us.
+ return None
+
+ return skipTestIfFn(is_compiler_clang_with_ubsan)(func)
+
def skipUnlessAddressSanitizer(func):
"""Decorate the item to skip test unless Clang -fsanitize=thread is supported."""
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-objc/TestDataFormatterObjC.py b/packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-objc/TestDataFormatterObjC.py
index d0a1728b87e6..bc39d8d7b152 100644
--- a/packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-objc/TestDataFormatterObjC.py
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-objc/TestDataFormatterObjC.py
@@ -186,16 +186,27 @@ class ObjCDataFormatterTestCase(TestBase):
def nsnumber_data_formatter_commands(self):
# Now enable AppKit and check we are displaying Cocoa classes correctly
- self.expect('frame variable num1 num2 num3 num4 num5 num6 num7 num9',
+ self.expect('frame variable num1 num2 num3 num5 num6 num7 num9',
substrs=['(NSNumber *) num1 = ', ' (int)5',
'(NSNumber *) num2 = ', ' (float)3.1',
'(NSNumber *) num3 = ', ' (double)3.14',
- '(NSNumber *) num4 = ', ' (long)-2',
'(NSNumber *) num5 = ', ' (char)65',
'(NSNumber *) num6 = ', ' (long)255',
'(NSNumber *) num7 = ', '2000000',
'(NSNumber *) num9 = ', ' (short)-31616'])
+
+ self.runCmd('frame variable num4', check=True)
+ output = self.res.GetOutput()
+ i128_handled_correctly = False
+
+ if output.find('long') >= 0:
+ i128_handled_correctly = (output.find('(long)-2') >= 0)
+ if output.find('int128_t') >= 0:
+ i128_handled_correctly = (output.find('(int128_t)18446744073709551614') >= 0) # deliberately broken, should be ..14
+
+ self.assertTrue(i128_handled_correctly, "Expected valid output for int128_t; got " + output)
+
self.expect('frame variable num_at1 num_at2 num_at3 num_at4',
substrs=['(NSNumber *) num_at1 = ', ' (int)12',
'(NSNumber *) num_at2 = ', ' (int)-12',
diff --git a/packages/Python/lldbsuite/test/functionalities/ubsan/basic/Makefile b/packages/Python/lldbsuite/test/functionalities/ubsan/basic/Makefile
new file mode 100644
index 000000000000..6e7d19b6f48c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/ubsan/basic/Makefile
@@ -0,0 +1,6 @@
+LEVEL = ../../../make
+
+C_SOURCES := main.c
+CFLAGS_EXTRAS := -fsanitize=undefined -g
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/ubsan/basic/TestUbsanBasic.py b/packages/Python/lldbsuite/test/functionalities/ubsan/basic/TestUbsanBasic.py
new file mode 100644
index 000000000000..8dcee97e32f5
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/ubsan/basic/TestUbsanBasic.py
@@ -0,0 +1,90 @@
+"""
+Tests basic UndefinedBehaviorSanitizer support (detecting an alignment error).
+"""
+
+import os
+import time
+import lldb
+from lldbsuite.test.lldbtest import *
+from lldbsuite.test.decorators import *
+import lldbsuite.test.lldbutil as lldbutil
+import json
+
+
+class UbsanBasicTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @skipUnlessUndefinedBehaviorSanitizer
+ def test(self):
+ self.build()
+ self.ubsan_tests()
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ self.line_align = line_number('main.c', '// align line')
+
+ def ubsan_tests(self):
+ # Load the test
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.expect(
+ "file " + exe,
+ patterns=["Current executable set to .*a.out"])
+
+ self.runCmd("run")
+
+ process = self.dbg.GetSelectedTarget().process
+ thread = process.GetSelectedThread()
+ frame = thread.GetSelectedFrame()
+
+ # the stop reason of the thread should be breakpoint.
+ self.expect("thread list", "A ubsan issue should be detected",
+ substrs=['stopped', 'stop reason ='])
+
+ stop_reason = thread.GetStopReason()
+ self.assertEqual(stop_reason, lldb.eStopReasonInstrumentation)
+
+ # test that the UBSan dylib is present
+ self.expect(
+ "image lookup -n __ubsan_on_report",
+ "__ubsan_on_report should be present",
+ substrs=['1 match found'])
+
+ # We should be stopped in __ubsan_on_report
+ self.assertTrue("__ubsan_on_report" in frame.GetFunctionName())
+
+ # The stopped thread backtrace should contain either 'align line'
+ found = False
+ for i in range(thread.GetNumFrames()):
+ frame = thread.GetFrameAtIndex(i)
+ if frame.GetLineEntry().GetFileSpec().GetFilename() == "main.c":
+ if frame.GetLineEntry().GetLine() == self.line_align:
+ found = True
+ self.assertTrue(found)
+
+ backtraces = thread.GetStopReasonExtendedBacktraces(
+ lldb.eInstrumentationRuntimeTypeUndefinedBehaviorSanitizer)
+ self.assertTrue(backtraces.GetSize() == 1)
+
+ self.expect(
+ "thread info -s",
+ "The extended stop info should contain the UBSan provided fields",
+ substrs=[
+ "instrumentation_class",
+ "memory_address",
+ "description",
+ "filename",
+ "line",
+ "col"])
+
+ output_lines = self.res.GetOutput().split('\n')
+ json_line = '\n'.join(output_lines[2:])
+ data = json.loads(json_line)
+
+ self.assertEqual(data["instrumentation_class"], "UndefinedBehaviorSanitizer")
+ self.assertEqual(data["description"], "misaligned-pointer-use")
+ self.assertEqual(data["filename"], "main.c")
+ self.assertEqual(data["line"], self.line_align)
+
+ self.runCmd("continue")
diff --git a/packages/Python/lldbsuite/test/functionalities/ubsan/basic/main.c b/packages/Python/lldbsuite/test/functionalities/ubsan/basic/main.c
new file mode 100644
index 000000000000..4991fc074d09
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/ubsan/basic/main.c
@@ -0,0 +1,4 @@
+int main() {
+ int data[4];
+ return *(int *)(((char *)&data[0]) + 2); // align line
+}
diff --git a/packages/Python/lldbsuite/test/lang/objc/objc-new-syntax/TestObjCNewSyntax.py b/packages/Python/lldbsuite/test/lang/objc/objc-new-syntax/TestObjCNewSyntax.py
index 57f373545380..96c5a33f14b0 100644
--- a/packages/Python/lldbsuite/test/lang/objc/objc-new-syntax/TestObjCNewSyntax.py
+++ b/packages/Python/lldbsuite/test/lang/objc/objc-new-syntax/TestObjCNewSyntax.py
@@ -121,8 +121,6 @@ class ObjCNewSyntaxTestCase(TestBase):
'7.0.0'])
@skipIf(macos_version=["<", "10.12"])
@expectedFailureAll(archs=["i[3-6]86"])
- @expectedFailureAll(
- bugnumber="rdar://32777981")
def test_update_dictionary(self):
self.runToBreakpoint()
@@ -165,8 +163,6 @@ class ObjCNewSyntaxTestCase(TestBase):
'7.0.0'])
@skipIf(macos_version=["<", "10.12"])
@expectedFailureAll(archs=["i[3-6]86"])
- @expectedFailureAll(
- bugnumber="rdar://32777981")
def test_dictionary_literal(self):
self.runToBreakpoint()