aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <behlendorf1@llnl.gov>2010-08-26 18:22:58 +0000
committerBrian Behlendorf <behlendorf1@llnl.gov>2010-08-31 20:41:27 +0000
commitc9c0d073da561bcbefbdf09c87fc75b227415619 (patch)
tree7daee55ae61526107f421de48171573fa5a15d28 /Makefile.am
parent40b84e7aec6392187722e61e5a4a853b530bf60f (diff)
downloadsrc-c9c0d073da561bcbefbdf09c87fc75b227415619.tar.gz
src-c9c0d073da561bcbefbdf09c87fc75b227415619.zip
Add build system
Add autoconf style build infrastructure to the ZFS tree. This includes autogen.sh, configure.ac, m4 macros, some scripts/*, and makefiles for all the core ZFS components.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000000..3689d1f8f9a5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,56 @@
+include $(top_srcdir)/config/rpm.am
+include ${top_srcdir}/config/deb.am
+include ${top_srcdir}/config/tgz.am
+
+if CONFIG_USER
+USER_DIR = config etc man scripts lib cmd
+endif
+if CONFIG_KERNEL
+KERNEL_DIR = module
+endif
+SUBDIRS = $(USER_DIR) $(KERNEL_DIR)
+
+AUTOMAKE_OPTIONS = foreign dist-zip
+EXTRA_DIST = autogen.sh zfs.spec.in zfs-modules.spec.in
+EXTRA_DIST += config/config.awk config/rpm.am config/deb.am config/tgz.am
+EXTRA_DIST += META DISCLAIMER COPYRIGHT GIT README.markdown
+EXTRA_DIST += OPENSOLARIS.LICENSE ZFS.RELEASE
+
+noinst_HEADERS = zfs_config.h
+
+distclean-local::
+ -$(RM) -R autom4te*.cache
+ -find . \( -name SCCS -o -name BitKeeper -o -name .svn -o -name CVS \
+ -o -name .pc -o -name .hg -o -name .git \) -prune -o \
+ \( -name '*.orig' -o -name '*.rej' -o -name '*~' \
+ -o -name '*.bak' -o -name '#*#' -o -name '.*.orig' \
+ -o -name '.*.rej' -o -name 'aclocal.m4' -o -size 0 \
+ -o -name '*%' -o -name '.*.cmd' -o -name 'core' \
+ -o -name 'Makefile' -o -name 'Module.symvers' \
+ -o -name '*.order' -o -name '*.markers' \
+ -o -name '.script-config' \) \
+ -type f -print | xargs $(RM)
+
+if CONFIG_KERNEL
+install-data-local:
+ destname=zfs-$(ZFS_META_VERSION)/$(LINUX_VERSION); \
+ instdest=$(DESTDIR)/usr/src/$$destname; \
+ echo "${ZFS_META_VERSION}" >$$instdest/zfs.release; \
+ for instfile in $(noinst_HEADERS) module/$(LINUX_SYMBOLS); do \
+ $(INSTALL) -D $$instfile $$instdest/$$instfile; \
+ done
+endif
+
+ctags:
+ $(RM) $(top_srcdir)/tags
+ find $(top_srcdir) -name .git -prune -o -name '*.[hc]' | xargs ctags
+
+etags:
+ $(RM) $(top_srcdir)/TAGS
+ find $(top_srcdir) -name .pc -prune -o -name '*.[hc]' | xargs etags -a
+
+tags: ctags etags
+
+pkg: @DEFAULT_PACKAGE@
+pkg-modules: @DEFAULT_PACKAGE@-modules
+pkg-utils: @DEFAULT_PACKAGE@-utils