aboutsummaryrefslogtreecommitdiff
path: root/tools/clang-fuzzer/proto-to-cxx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/clang-fuzzer/proto-to-cxx/CMakeLists.txt')
-rw-r--r--tools/clang-fuzzer/proto-to-cxx/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/clang-fuzzer/proto-to-cxx/CMakeLists.txt b/tools/clang-fuzzer/proto-to-cxx/CMakeLists.txt
new file mode 100644
index 000000000000..910b793e0e0d
--- /dev/null
+++ b/tools/clang-fuzzer/proto-to-cxx/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD})
+set(CMAKE_CXX_FLAGS ${CXX_FLAGS_NOFUZZ})
+
+# Hack to bypass LLVM's CMake source checks so we can have both a library and
+# an executable built from this directory.
+set(LLVM_OPTIONAL_SOURCES proto_to_cxx.cpp proto_to_cxx_main.cpp)
+
+add_clang_library(clangProtoToCXX proto_to_cxx.cpp
+ DEPENDS clangCXXProto
+ LINK_LIBS clangCXXProto ${PROTOBUF_LIBRARIES}
+ )
+
+add_clang_executable(clang-proto-to-cxx proto_to_cxx_main.cpp)
+target_link_libraries(clang-proto-to-cxx PRIVATE clangProtoToCXX)