aboutsummaryrefslogtreecommitdiff
path: root/ptdump/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ptdump/CMakeLists.txt')
-rw-r--r--ptdump/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/ptdump/CMakeLists.txt b/ptdump/CMakeLists.txt
new file mode 100644
index 000000000000..66a3b615e573
--- /dev/null
+++ b/ptdump/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Copyright (c) 2013-2019, Intel Corporation
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+# * Neither the name of Intel Corporation nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+include_directories(
+ include
+ ../libipt/internal/include
+)
+
+set(PTDUMP_FILES
+ src/ptdump.c
+ ../libipt/src/pt_last_ip.c
+ ../libipt/src/pt_cpu.c
+ ../libipt/src/pt_time.c
+)
+
+if (CMAKE_HOST_UNIX)
+ set(PTDUMP_FILES ${PTDUMP_FILES} ../libipt/src/posix/pt_cpuid.c)
+endif (CMAKE_HOST_UNIX)
+
+if (CMAKE_HOST_WIN32)
+ set(PTDUMP_FILES ${PTDUMP_FILES} ../libipt/src/windows/pt_cpuid.c)
+endif (CMAKE_HOST_WIN32)
+
+add_executable(ptdump
+ ${PTDUMP_FILES}
+)
+
+target_link_libraries(ptdump libipt)
+if (SIDEBAND)
+ target_link_libraries(ptdump libipt-sb)
+endif (SIDEBAND)