aboutsummaryrefslogtreecommitdiff
path: root/lib/Target/SystemZ/MCTargetDesc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/SystemZ/MCTargetDesc/CMakeLists.txt')
-rw-r--r--lib/Target/SystemZ/MCTargetDesc/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/Target/SystemZ/MCTargetDesc/CMakeLists.txt b/lib/Target/SystemZ/MCTargetDesc/CMakeLists.txt
index 2ac90164721f..822df097a37d 100644
--- a/lib/Target/SystemZ/MCTargetDesc/CMakeLists.txt
+++ b/lib/Target/SystemZ/MCTargetDesc/CMakeLists.txt
@@ -3,5 +3,12 @@ add_llvm_library(LLVMSystemZDesc
SystemZMCAsmInfo.cpp
)
+add_llvm_library_dependencies(LLVMSystemZDesc
+ LLVMMC
+ LLVMSystemZInfo
+ )
+
+add_dependencies(LLVMSystemZDesc SystemZCommonTableGen)
+
# Hack: we need to include 'main' target directory to grab private headers
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/.. ${CMAKE_CURRENT_BINARY_DIR}/..)