aboutsummaryrefslogtreecommitdiff
path: root/contrib/libxo/tests/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libxo/tests/core/Makefile.am')
-rw-r--r--contrib/libxo/tests/core/Makefile.am24
1 files changed, 20 insertions, 4 deletions
diff --git a/contrib/libxo/tests/core/Makefile.am b/contrib/libxo/tests/core/Makefile.am
index 92f5f364b74b..0131a6f50ac5 100644
--- a/contrib/libxo/tests/core/Makefile.am
+++ b/contrib/libxo/tests/core/Makefile.am
@@ -21,7 +21,8 @@ test_06.c \
test_07.c \
test_08.c \
test_09.c \
-test_10.c
+test_10.c \
+test_11.c
test_01_test_SOURCES = test_01.c
test_02_test_SOURCES = test_02.c
@@ -33,6 +34,7 @@ test_07_test_SOURCES = test_07.c
test_08_test_SOURCES = test_08.c
test_09_test_SOURCES = test_09.c
test_10_test_SOURCES = test_10.c
+test_11_test_SOURCES = test_11.c
# TEST_CASES := $(shell cd ${srcdir} ; echo *.c )
@@ -41,6 +43,10 @@ noinst_PROGRAMS = ${TEST_CASES:.c=.test}
LDADD = \
${top_builddir}/libxo/libxo.la
+if HAVE_HUMANIZE_NUMBER
+LDADD += -lutil
+endif
+
EXTRA_DIST = \
${TEST_CASES} \
${addprefix saved/, ${TEST_CASES:.c=.T.err}} \
@@ -70,13 +76,18 @@ valgrind:
#TEST_TRACE = set -x ;
-TEST_ONE = \
- LIBXO_OPTIONS=:W$$fmt \
+TEST_JIG = \
${CHECKER} ./$$base.test ${TEST_OPTS} \
> out/$$base.$$fmt.out 2> out/$$base.$$fmt.err ; \
${DIFF} -Nu ${srcdir}/saved/$$base.$$fmt.out out/$$base.$$fmt.out ${S2O} ; \
${DIFF} -Nu ${srcdir}/saved/$$base.$$fmt.err out/$$base.$$fmt.err ${S2O}
+TEST_ONE = \
+ LIBXO_OPTIONS=:W$$fmt ${TEST_JIG}
+
+TEST_TWO = \
+ LIBXO_OPTIONS=warn,encoder=test ${TEST_JIG}
+
TEST_FORMATS = T XP JP HP X J H HIPx
test tests: ${bin_PROGRAMS}
@@ -87,6 +98,11 @@ test tests: ${bin_PROGRAMS}
echo "... $$test ... $$fmt ..."; \
${TEST_ONE}; \
true; \
+ done) ; \
+ (for fmt in E; do \
+ echo "... $$test ... $$fmt ..."; \
+ ${TEST_TWO}; \
+ true; \
done) \
done)
@@ -96,7 +112,7 @@ one:
accept:
-@(for test in ${TEST_CASES} ; do \
base=`${BASENAME} $$test .c` ; \
- (for fmt in ${TEST_FORMATS}; do \
+ (for fmt in ${TEST_FORMATS} E; do \
echo "... $$test ... $$fmt ..."; \
${CP} out/$$base.$$fmt.out ${srcdir}/saved/$$base.$$fmt.out ; \
${CP} out/$$base.$$fmt.err ${srcdir}/saved/$$base.$$fmt.err ; \