aboutsummaryrefslogtreecommitdiff
path: root/contrib/libstdc++/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libstdc++/Makefile.am')
-rw-r--r--contrib/libstdc++/Makefile.am118
1 files changed, 0 insertions, 118 deletions
diff --git a/contrib/libstdc++/Makefile.am b/contrib/libstdc++/Makefile.am
deleted file mode 100644
index c1f17b651bc5..000000000000
--- a/contrib/libstdc++/Makefile.am
+++ /dev/null
@@ -1,118 +0,0 @@
-## Makefile for the toplevel directory of the GNU C++ Standard library.
-##
-## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003
-## Free Software Foundation, Inc.
-##
-## This file is part of the libstdc++ version 3 distribution.
-## Process this file with automake to produce Makefile.in.
-
-## This file is part of the GNU ISO C++ Library. This library is free
-## software; you can redistribute it and/or modify it under the
-## terms of the GNU General Public License as published by the
-## Free Software Foundation; either version 2, or (at your option)
-## any later version.
-
-## This library is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU General Public License for more details.
-
-## You should have received a copy of the GNU General Public License along
-## with this library; see the file COPYING. If not, write to the Free
-## Software Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301,
-## USA.
-
-include $(top_srcdir)/fragment.am
-
-if GLIBCXX_HOSTED
- hosted_source = libmath src po testsuite
-endif
-## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
-SUBDIRS = include libsupc++ $(hosted_source)
-
-ACLOCAL_AMFLAGS = -I . -I .. -I ../config
-
-# These rules are messy, but are hella worth it.
-doxygen:
- -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
- builddir=`${PWD_COMMAND}`; \
- ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
- --host_alias=${host_alias} \
- --mode=user $${srcdir} $${builddir})
-
-doxygen-maint:
- -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
- builddir=`${PWD_COMMAND}`; \
- ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
- --host_alias=${host_alias} \
- --mode=maint $${srcdir} $${builddir})
-
-doxygen-man:
- -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
- builddir=`${PWD_COMMAND}`; \
- ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
- --host_alias=${host_alias} \
- --mode=man $${srcdir} $${builddir})
-
-.PHONY: doxygen doxygen-maint doxygen-man
-
-# Handy forwarding targets.
-check-%:
- cd testsuite && $(MAKE) $@
-
-# Multilib support.
-MAKEOVERRIDES=
-
-# All the machinations with string instantiations messes up the
-# automake-generated TAGS rule. Make a simple one here.
-TAGS: tags-recursive $(LISP)
-
-# Work around what appears to be a GNU make bug handling MAKEFLAGS
-# values defined in terms of make variables, as is the case for CC and
-# friends when we are called from the top level Makefile.
-AM_MAKEFLAGS = \
- "AR_FLAGS=$(AR_FLAGS)" \
- "CC_FOR_BUILD=$(CC_FOR_BUILD)" \
- "CC_FOR_TARGET=$(CC_FOR_TARGET)" \
- "CFLAGS=$(CFLAGS)" \
- "CXXFLAGS=$(CXXFLAGS)" \
- "CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \
- "CFLAGS_FOR_TARGET=$(CFLAGS_FOR_TARGET)" \
- "INSTALL=$(INSTALL)" \
- "INSTALL_DATA=$(INSTALL_DATA)" \
- "INSTALL_PROGRAM=$(INSTALL_PROGRAM)" \
- "INSTALL_SCRIPT=$(INSTALL_SCRIPT)" \
- "LDFLAGS=$(LDFLAGS)" \
- "LIBCFLAGS=$(LIBCFLAGS)" \
- "LIBCFLAGS_FOR_TARGET=$(LIBCFLAGS_FOR_TARGET)" \
- "MAKE=$(MAKE)" \
- "MAKEINFO=$(MAKEINFO) $(MAKEINFOFLAGS)" \
- "PICFLAG=$(PICFLAG)" \
- "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
- "SHELL=$(SHELL)" \
- "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
- "exec_prefix=$(exec_prefix)" \
- "infodir=$(infodir)" \
- "libdir=$(libdir)" \
- "includedir=$(includedir)" \
- "prefix=$(prefix)" \
- "tooldir=$(tooldir)" \
- "gxx_include_dir=$(gxx_include_dir)" \
- "AR=$(AR)" \
- "AS=$(AS)" \
- "LD=$(LD)" \
- "RANLIB=$(RANLIB)" \
- "NM=$(NM)" \
- "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
- "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
- "DESTDIR=$(DESTDIR)" \
- "WERROR=$(WERROR)"
-
-# Subdir rules rely on $(FLAGS_TO_PASS)
-FLAGS_TO_PASS = $(AM_MAKEFLAGS)
-
-# Installation of distribution html documentation not yet supported
-# TODO: Write custom install-html rule.
-.PHONY: install-html
-install-html:
-