aboutsummaryrefslogtreecommitdiff
path: root/contrib/libio/tests/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libio/tests/configure.in')
-rw-r--r--contrib/libio/tests/configure.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/contrib/libio/tests/configure.in b/contrib/libio/tests/configure.in
new file mode 100644
index 000000000000..46deefbc8c95
--- /dev/null
+++ b/contrib/libio/tests/configure.in
@@ -0,0 +1,36 @@
+# This file is a shell script fragment that supplies the information
+# necessary for a configure script to process the program in
+# this directory. For more information, look at ../../configure.
+
+configdirs=
+srctrigger=tFile.cc
+srcname="test C++ input/output library"
+package_makefile_frag=Make.pack
+package_makefile_rules_frag=Make.pack.r
+
+# per-host:
+
+# per-target:
+
+TO_TOPDIR=../../
+ALL=' '
+XCINCLUDES='-I. -I.. -I$(srcdir) -I$(srcdir)/..'
+XCXXINCLUDES='-I. -I.. -I$(srcdir) -I$(srcdir)/..'
+MOSTLYCLEAN='*.o core $(JUNK_TO_CLEAN)'
+(. ${srcdir}/../config.shared) >${package_makefile_frag} 2>${package_makefile_rules_frag}
+
+if [ "${srcdir}" = "." ] ; then
+ if [ "${with_target_subdir}" != "." ] ; then
+ topsrcdir=${with_multisrctop}../../..
+ else
+ topsrcdir=${with_multisrctop}../..
+ fi
+else
+ topsrcdir=${srcdir}/../..
+fi
+
+if [ ! -d ${topsrcdir}/gcc ] ; then
+ echo "CHECK = check-iostream check-iostdio" >>${package_makefile_frag}
+fi
+
+# post-target: