aboutsummaryrefslogtreecommitdiff
path: root/contrib/perl5/ext/SDBM_File/sdbm/Makefile.PL
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>2000-06-25 11:04:01 +0000
committerMark Murray <markm@FreeBSD.org>2000-06-25 11:04:01 +0000
commit120a02d4f3990e59fba1df18a155ff7233b4d827 (patch)
tree52ba93338b13aefd02a0055304a9eccfa0e049f5 /contrib/perl5/ext/SDBM_File/sdbm/Makefile.PL
parent7c312e6b6a7b1f9412f10365baf3c5eca8fa5649 (diff)
Vendor import of Perl 5.006
Notes
Notes: svn path=/vendor/perl5/dist/; revision=62076
Diffstat (limited to 'contrib/perl5/ext/SDBM_File/sdbm/Makefile.PL')
-rw-r--r--contrib/perl5/ext/SDBM_File/sdbm/Makefile.PL8
1 files changed, 5 insertions, 3 deletions
diff --git a/contrib/perl5/ext/SDBM_File/sdbm/Makefile.PL b/contrib/perl5/ext/SDBM_File/sdbm/Makefile.PL
index e6fdcf93069e..4453dea1fda1 100644
--- a/contrib/perl5/ext/SDBM_File/sdbm/Makefile.PL
+++ b/contrib/perl5/ext/SDBM_File/sdbm/Makefile.PL
@@ -42,12 +42,14 @@ INST_STATIC = libsdbm$(LIB_EXT)
}
sub MY::top_targets {
+ my $noecho = shift->{NOECHO};
+
my $r = '
all :: static
- $(NOECHO) $(NOOP)
+ ' . $noecho . '$(NOOP)
config ::
- $(NOECHO) $(NOOP)
+ ' . $noecho . '$(NOOP)
lint:
lint -abchx $(LIBSRCS)
@@ -58,7 +60,7 @@ lint:
# variables into the environment so $(MYEXTLIB) is set in here to this
# value which can not be built.
sdbm/libsdbm.a:
- $(NOECHO) $(NOOP)
+ ' . $noecho . '$(NOOP)
' unless $^O eq 'VMS';
return $r;