aboutsummaryrefslogtreecommitdiff
path: root/contrib/cvs/lib/Makefile.am
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2008-01-13 05:49:32 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2008-01-13 05:49:32 +0000
commitcf9c5c1a566bda1bc3eaeee00091c457c12cc68c (patch)
tree8d8aae4a8bb167db64e23bb7f76f39014f36d45f /contrib/cvs/lib/Makefile.am
parent83c36f7f985e86e33d46bc7d7fc4e648ca22226b (diff)
Import cvs-1.11.22 onto vendor branch.
Notes
Notes: svn path=/vendor/cvs/dist/; revision=175261
Diffstat (limited to 'contrib/cvs/lib/Makefile.am')
-rw-r--r--contrib/cvs/lib/Makefile.am26
1 files changed, 22 insertions, 4 deletions
diff --git a/contrib/cvs/lib/Makefile.am b/contrib/cvs/lib/Makefile.am
index 91cdeea03508..cade9e0301e6 100644
--- a/contrib/cvs/lib/Makefile.am
+++ b/contrib/cvs/lib/Makefile.am
@@ -1,8 +1,10 @@
## Process this file with automake to produce Makefile.in
# Makefile for library files used by GNU CVS.
-# Copyright (C) 1986, 1987, 1988, 1989, 1990, 1991, 1992, 1993, 1994,
-# 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003
-# Free Software Foundation, Inc.
+#
+# Copyright (C) 1986-2005 The Free Software Foundation, Inc.
+#
+# Portions Copyright (C) 1998-2005 Derek Price, Ximbiot <http://ximbiot.com>,
+# and others.
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -86,7 +88,23 @@ EXTRA_DIST = \
ChangeLog.fsf \
build_lib.com \
libcvs.dep libcvs.dsp libcvs.mak \
- xgssapi.h
+ xgssapi.h \
+ test-getdate.sh
+
+TESTS =
+MOSTLYCLEANFILES =
+check_PROGRAMS =
+
+# Test GNULIB getdate module.
+TESTS += test-getdate.sh
+MOSTLYCLEANFILES += getdate-expected getdate-got getdate.diff
+# Program required by test-getdate.sh for testing getdate.y.
+check_PROGRAMS += getdate
+EXTRA_DIST += $(check_PROGRAMS)
+getdate_SOURCES = getdate.y
+getdate_CPPFLAGS = -DTEST
+##getdate_LDADD = \
+## $(noinst_LIBRARIES)
# For the xsize module from GNULIB.
libcvs_a_SOURCES += xsize.h